Home > MVP > Users > Microphone access to the RingCentral app on your desktop or web browser is blocked on a Windows computer

Microphone access to the RingCentral app on your desktop or web browser is blocked on a Windows computer

Last updated on September 27, 2022

When using the RingCentral app, mic access is blocked

When using the RingCentral app on your desktop or web browser on a Windows computer, you see an error message that access to your microphone is blocked. 

Granting mic access to the RingCentral app

One or more of the following steps can solve this problem.

Select your audio source in the RingCentral app on your desktop or web browser

Change app permissions in Windows

You may need to adjust Windows’ app permissions to let the RingCentral app on your desktop or web browser access your microphone.

Restart your docking station

If your microphone uses a docking station, turn the docking station off, wait 30 seconds, then turn it back on before connecting your microphone.

Update your microphone’s drivers

Go to the website of your microphone’s manufacturer and search for drivers for your device. You may need to download and install new drivers.
Home > MVP > Users
Desktop & web

How do I allow microphone access for the RingCentral app on a Windows computer?

Last updated on March 07, 2022

Table of contents

Issue

When making a call on RingCentral Phone in the RingCentral app on a Windows computer, the “Access to your microphone is blocked. Change your system settings to allow RingCentral to use your microphone” banner shows up.

Affected environments

RingCentral Phone in the RingCentral app for Windows.

Cause

Microphone access for RingCentral app is disabled in your Windows computer’s privacy settings.

Resolution

Allow microphone access for RingCentral on your Windows computer. You can find troubleshooting instructions here.
 
When you connect a headset or speaker to your computer, ensure that it is the audio source in the RingCentral desktop app for inbound and outbound audio to work. Set the default microphone and speaker settings. Learn more
 
If you are using a docking station, power it off, wait 30 seconds, then power it back on before connecting your microphone or headset device. Ensure that the device drivers have been properly installed and can be detected by the RingCentral app. Refer to the device user manual for assistance if needed.
 
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