Access, service, and grow your account from here.
Search
Contact us
Save time by chatting with RChee, available online 24/7.
Submit a case
The most direct way to match you to the right expert on your issue. Responses within 48 hours.
Contact us
FOR SALES
1 (888) 898-4591
FOR SUPPORT
1 (888) 898-4591
Search resources
Submit a case
Contact us
FOR SALES
FOR SUPPORT
Welcome to MyRingCentral
Hi, ${extension.contact.firstName}!
Welcome to MyRingCentral
Hi, ${extension.contact.firstName}!
Desktop & web

Why is the audio not passed to TV when Poly X30 or
Poly X50 is set to device mode in RingCentral Rooms?

Last updated on November 24, 2021

Table of contents

Issue

When a third-party device (i.e., DVD player) is connected to the Poly X30 or X50, HDMI audio is not passed to the TV even with the Poly devices set to Device Mode.

Affected environments

  • RingCentral Rooms for Poly
  • Poly X30
  • Poly X50

Cause

This is currently not supported. Device Mode is designed to utilize USB for connectivity to the audio devices.
© 2022 RingCentral, Inc. All rights reserved.
Thanks!
We've sent you a link, please check your phone!
Please allow a full minute between phone number submissions.
There was an issue with SMS sending. Please try again. If the issue persists, please contact support.