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RingCentral Phone - Troubleshooting Plantronics Integration Disabled

This article provides the troubleshooting steps to enable Plantronics Headset Integration with RingCentral Phone.

How to resolve RingCentral Phone Plantronics Integration Disabled 

Issue:

Unable to use the Plantronics Integration feature with RingCentral Phone. User sees the message "
Error: The application cannot connect to the Plantronics HUB which enables the call control features on the Plantronics audio device. Please install the Plantronics HUB software from www.plantronics.com.
"

Environment:

RingCentral Phone

Plantronics Hub

 

Causes:

A similar error message will be displayed in other specific use-cases listed below:

1) If integration was enabled previously but the application cannot communicate with HUB any longer. 

2) If a user tries to enable integration and we cannot connect to HUB. 

3) If a user uninstalls HUB while integration is enabled.

NOTE:
You may go to  RingCentral Phone - Download and Install Plantronics Hub  for more information Plantronics HUB installation.

 

Solution:

Install/Reinstall Plantronics Hub to enable Plantronics Headset integration with RingCentral Phone.  Download Plantronics Hub

In this article

How to resolve RingCentral Phone Plantronics Integration Disabled 
Issue:
Environment:
Causes:
Solution:
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