Why can’t I join a RingCentral Webinar via Internet Explorer 11?

Last updated on March 15, 2022

Table of contents

Issue

Webinar attendees do not get an unsupported browser message when joining a webinar using Internet Explorer 11. The page just continues to load. 

Affected environments

RingCentral Webinar.

Cause

RingCentral Webinar no longer supports Internet Explorer 11.

Resolution

Attendee can join using a supported browser or mobile device. Learn more.
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