Desktop & web

Intro to detecting incompatible or outdated
RingCentral Rooms apps

Last updated on November 24, 2021
To ensure RingCentral Rooms will run properly and keep up with the new features, it will automatically detect when:
  • Rooms and the controller are in incompatible versions
  • Rooms operating system (OS) is below the minimum supported OS version
  • Rooms app is below the minimum supported app version

Outdated host and controller devices

The host device will display a similar screen below when an update is needed.
Screen showing host device needs to be updated
The controller device will show a similar screen when it needs to be updated.
Screen showing controller device needs to be updated
© 1999-2022 RingCentral, Inc. Tutti i diritti riservati.
Close X
Thanks!
We've sent you a link, please check your phone!
Please allow a full minute between phone number submissions.
There was an issue with SMS sending. Please try again. If the issue persists, please contact support.